Project Details Web Part was unable to load After Project Server Restore

I have recently restored a Project Server 2010 Farm from Production to Test server,While performing a smoke test by trying to open Project Details Page (PDP) , I encountered the following error 

"This Web Part was unable to load."

PDPDetails

I performed a quick investigatory by editing the  PDP, add a new Project Fields Web Part or any another Project Web Part to ensure that the issue is not related to project data.but unfortunately the issue seem in all Project Web Part type.

Cause :

After I checked the log file with the related correlation ID, I found out the PWAURL property still set to the Production URL and need to unset.

Solution

To unset the PWAURL property,you should follow the mentioned steps below:

  • Open SharePoint 2010 Management Shell as Administrator.
  • Run the following code one by one.
  • Check the  PWAURL that was set to old link actually.

PWAURL

  • Run the following code to set PWAURL to epmty.
    • $Web.AllProperties["PWAURL"]=""
    • $Web.Update()
  • The PDP should now been open properly.

PDPLoaded

Enjoy 🙂

Advertisements

2 thoughts on “Project Details Web Part was unable to load After Project Server Restore

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s