Sorry, something went wrong App Management Shared Service Proxy is not installed in SharePoint Server 2013

When I tried to elevate permissions for workflow, specifically in the step of Grant Permission to an App by navigating to http://{hostname}/{catalog site}/_layouts/15/appinv.aspx  then I set the App Identifier and I clicked Lookup,

Grant permission to an App

But unfortunately, I got the following error.

Sorry, something went wrong App Management Shared Service Proxy is not installed

App Management Shared Service Proxy is not installed.png

Cause:

This issue occurs because of App Management Service is not installed and configured.

Solution:

To configure App Managment Service, you should follow the mentioned steps below:

  • Open Central Administration as administrator > Application Management > Manage Service Application.

manage service application

  • From the ribbon Click on New > App Management Service.

New App Management Service Application 0

  • The following dialog will show to you > Type the name of the service > Modify the DBName as you need.

New App Management Service Application

  • Type the name of the application pool > Select Managed account or create a new one.

New App Management Service Application 1

  • Click OK to create an app management service.

New App Management Service Application 2

  • The app management service should be now created.

New App Management Service Application 3

  • As above shown, the app management service proxy stopped.so that to start it, you will now need to run the app management service by navigating to > System Settings > Manage Services on server.
  • Manage Services On ServerFind App management service > Below Action>  Click on start to start the service.

Start App Management Service Application.png

  • The App Managment Service should be now started.

Start App Management Service Application 1

  • Go back to manage service applications.

Application Management - Manage Service Applications

  • The App Management Service Application Proxy should now be started.

New App Management Service Application 4

  • Go to Site Settings > Below Site Actions > Select Manage site features.Manage Site Features
  • Activate Workflows can use app permissions feature.

Workflows can use app permissions.png

  • Go to Site Settings > Site app permissions.

Site app permissions.png

  • Make sure that you copied the client section of the App Identifier between the last “|” and the “@” sign, as shown below.

App Identifier

  • Go back to grant to an app http://{hostname}/{catalog site}/_layouts/15/appinv.aspx .
  • Paste the client section of App Identifier to the App Id field and then click Lookup to fetch the required info.

Grant permission to an App

  • Click on lookup to retrieve its related information that should be now worked properly.

Grant permission to an App 1.png

Note : If the lookup button was unable to retrieve its related information check Lookup an App Id was unable to retrieve its related data during granting permission to an app in SharePoint 2013. to overcome this issue.

Enjoy 🙂

See also

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s